AnsweredAssumed Answered

S32K144 Development kit no longer uploads.

Question asked by Matthew Dreisbach on Mar 28, 2019
Latest reply on Apr 1, 2019 by Paul Domanico

Mike Doidge 

 

We have 3 S32k144 development boards that are in a bricked state, this occurred unexpectedly and the boards had no problems before. We have no problem uploading to most of our boards but these three have issues, the reset LED is not high. We are able to recognize the broken boards on the windows explorer but unable to upload to them. Here is the error we receive in S32K design studio. 

 

 

When hitting retry, we see the reset LED flash but the error pops back up. The rest of our development boards upload without issue. We have tried updating the P&E micro firmware in the boot loader but this has not helped.

 

We also tried to upload a previously built .mot file to the board over windows explorer but that had no effect (although the files transferred without issue)

 

This problem appeared while uploading auto-generated code from the NXP simulation library for the S32K. 

Outcomes