AnsweredAssumed Answered

i.MX8-MEVK Wifi Support

Question asked by Shengye Wan on Mar 25, 2019
Latest reply on Mar 27, 2019 by Rita Wang

Hi experts,

 

I was recently working with i.MX 8M Evaluation Kit, and I set up the board with a self-built fsl-image-qt5-validation-imx image by following the i.MX Yocto Project User's Guide.

Now, if I run command ifconfig, I get only eth0 and lo. 

By checking iwconfig, I get p2p0, wlan0, eth0, and lo. However, I cannot bring the wlan0 up correctly.

 

I tried to configure the wifi name and password by:

1) editing the file /ect/wpa-supplicant with wifi configuration, and then execute the command: 

wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant.conf

which gives me the error:

Successfully initialized wpa_supplicantwext -i wlan0 -c /etc/wpa_supplicant.conf

rfkill: Cannot open RFKILL contro[  557.160543] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

l device

ioctl[SIOCSIWPMKSA]: Invalid argument

ioctl[SIOCSIWPMKSA]: Invalid argument

 

2) Execute the iwconfig command:

iwconfig wlan0 essid $SSID key s:$PASSWORD

which gives me the error:

Error for wireless request "Set Encode" (8B2A) :

    SET failed on device wlan0 ; Invalid argument.

Any idea about how to enable the wifi connection?

 

Simon

 

 

Outcomes