AnsweredAssumed Answered

I cannot debug my FRDM-KW41Z as MCUXpresso cannot link to probes

Question asked by Colin Gerrish on Mar 19, 2019
Latest reply on Mar 23, 2019 by Colin Gerrish

I have just downloaded the MCUXpresso 10.3.1 build 2233 (32-bit) for the first time to use with my new FRDM-KW41Z board and I have hit a snag when I try to debug any program in that it says it cannot link any probe.

 

I think it is a case of me trying to run before crawling without knowing what I was doing so I am guessing I have messed up some settings along the way.

 

Anyhow, I have worked out that the FRDM-KW41Z board uses the SEGGER J-Link USB drivers (the clue I eventually stumbled upon was in the device flash folder where there is an html that redirects to SEGGER).

 

I then found the SEGGER folder on my Windows 10 computer and prior to stumbling upon the JLinkConfig program I even downloaded another version of SEGGER, so now I have two versions 6.4.2 and 6.4.4. When using the JLinkConfig.exe application (using either SEGGER version) it would find my board and it shows the serial number etc. and can confirm that firmware is ok.

 

So it would seem that the board and openSDA driver looks ok to me.

 

Back to MCUXpresso. So if I click on Debug option or click on it when holding shift key to force it to "probe rediscovery" I end up at the same place. A dialogue box opens for probes discovered with the message "No compatible probes available." The IDE console also has a message "No probes found". Now at some stage during the "let me try this stab-in-the-dark" approach I would sometimes get an option to choose a SEGGER file. Either I got the right file choice or not, as this option no longer pops up.

 

I then discovered a "Debug Config" option. Here I tried clicking on the "GDB SEGGER Interface Debugging" option to create a new launch configuration. Then clicking on the "debugging" tab it gave me a bunch of config options. But here when clicking on the "Device" drop-down menu the KW41Z board is not listed. So I could not proceed any further.

 

I am now at a complete loss as to what to do next.

 

I am also rather curious to know how does one change the SEGGER version for example as cannot see in the IDE how this is linked.

 

Anyhow, any advice and assistance will be greatly appreciated.

 

Thanks

 

 

 

Outcomes