AnsweredAssumed Answered

LinkServer Debugging failing in MCUXpressoIDE 10.3.1

Question asked by Thomas Hardt on Mar 15, 2019
Latest reply on Apr 1, 2019 by Thomas Hardt

I'm trying to debug a new FRDM K22F board running an unmodified frdmk22f_freertos_generic project from the SDK. However, after building the project without any errors (as far as I can tell), and attempting to debug it using the given frdmk22f_freertos_generic LinkServer Debug.launch, the IDE throws up an error message saying "'Launching frdmk22f_freertos_generic LinkServer Debug' has encountered a problem. Could not determine GDB version using command: arm-none-eabi-gdb --version"

Under details this message is repeated again.

I tried running arm-none-eabi-gdb --version from "Project->Utilities->Open command prompt here" which runs the program without issue, giving correct version information, although it does appear to hang for a bit before giving its output. I wonder if this could be causing the debug launcher to timeout somehow? And if that's the case, how would I circumvent this or disable a timeout? Could something else be causing the problem?

 

I've already tried restarting the PC running MCUXpressoIDE, and reinstalling the IDE as well, but this issue is persisting.

It also appears that this gdb version check is happening before it flashes the board, since the board is still running its factory RGBLED demo.

Outcomes