AnsweredAssumed Answered

LS1043ARDB recover NOR Flash Bank 0 and 4

Question asked by Kedar Lahurikar on Mar 11, 2019
Latest reply on Mar 14, 2019 by Yiping Wang

I might have corrupted both the NOR Flash banks of LS1043ARDB, how can I recover or boot from IF NOR now? I have created a Hard Coded RCW Override project, using Target Initialization file to debug.

 

I observed that I don't see “Hello from Core#0” displayed at the console output, (Attached - Debug_info). But I am not sure if I should be seeing this (I saw this in 'RAM boot using CodeWarrior on LS1046ARDB').

Probably, my target initialization file is incorrect or def Init_DDR () may not be properly functioning. Could you please share the correct Target Init File for LS1043ARDB. (Attached - Target_Init_File.txt)

 

I tried programming the 'u-boot-nor-2016.01+fslgit-r0.bin' to the NOR flash (Attached - FlashProgrammer_NOR), however I am not sure what offsets I should write this at. I tried both 0x0 and 0x100000 but board doesn't boot from NOR at all after setting DIP switches for NOR.

 

PS: I have the board bootable from NAND flash and SD card. I am using respective 'u-boot-with-spl-pbl.bin' images (generated from QorIQ SDK) to boot up the board. How and which images can be used to make the board bootable from IF NOR. 

Outcomes