AnsweredAssumed Answered

CodeWarrior 5.9 debugging with multilink: unable to put breakpoints on executed instructions.

Question asked by Eugenia Suarez on Mar 11, 2019
Latest reply on Mar 19, 2019 by TomE

I have the following piece of code for coldfire V2 MCF52258:

 

 

According CW tutorial, dashes at left column tell us where we can set a breakpoint. As it can be seen, a low red point is tried to be put at instruction. You can think that it means that this code will not be executed as it has no dashes at left. 

IsolatedSetsBidir() is a function that will be executed under ETH arriving order. 

 

When I run this command script it should start to execute the code inside this function. tInteH3_IsolatedSetsBidir is a function that only will be called and executed if this commands launches IsolatedSetBidir(). So, if I can' t put a breakpoint here, this thing makes me think that it will not be executed. 

 

Actually, when I debug the execution thread doesn't stop where the breakpoint -at picture- is (when Ethernet command is received). But if I also have put a breakpoint inside tInteH3_IsolatedSetsBidir... "voila" it stops here. So, thread must be entering to IsolatedSetBidir(). It is no other way to call tInteH3_IsolatedSetsBidir.

 

I don't know why is it happening. Why I can not put a breakpoint in a place that is obviously executed? Is it a bug? 

 

Regards.

Outcomes