AnsweredAssumed Answered

iMX8: Waylandsink doesn't support UYVY?

Question asked by Kaartic Sivaraam Sankaranarayan on Feb 25, 2019
Latest reply on May 3, 2019 by Kaartic Sivaraam Sankaranarayan

Hi,

 

I'm using the sumo distribution for iMX8 on a iMX8M Quad EVK. That is the BSP based on kernel version 4.14.78. I tried to stream data from a camera sensor (connected to MIPI) that provides output in UYVY format. I tried to use the following Gstreamer pipeline to stream to the display:

 

 gst-launch-1.0 v4l2src ! video/x-raw,width=1920,height=1080 ! waylandsink -v
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Internal data stream error.
Additional debug info:
../../../../git/libs/gst/base/gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
streaming stopped, reason not-negotiated (-4)
Execution ended after 0:00:00.035448601
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

I know that the sensor is streaming as I see successful streaming via v4l2-ctl. Further, the following Gstreamer pipeline correctly shows the frame rate for us:

 

gst-launch-1.0 v4l2src ! video/x-raw,width=1920,height=1080 ! fpsdisplaysink video-sink=fakesink sync=false text-overlay=false -v

 

So, there's no issue with the sensor. I also checked the output of gst-inspect-1.0 waylandsink and ensured that waylandsink does support the UYVY format.

 

It's not clear why we get the error noted above. Any help would be very useful!

Outcomes