AnsweredAssumed Answered

U-Boot compilation error - Old GCC

Question asked by Shamanth Kudaligi Pranesharao on Feb 24, 2019
Latest reply on Feb 27, 2019 by Yiping Wang

I am trying to build U-boot for LS1046ARDB (ls104ardb_emmc_defconfig) using the Linux SDK (2.0). 

I am getting the following error:

make
scripts/kconfig/conf --syncconfig Kconfig
CHK include/config.h
UPD include/config.h
CFG u-boot.cfg
GEN include/autoconf.mk
GEN include/autoconf.mk.dep
CFG spl/u-boot.cfg
GEN spl/include/autoconf.mk
*** Your GCC is older than 6.0 and is not supported. 

 

Please note:

My OS is Ubuntu 14.04 because I followed the instructions provided by NXP on this Build error SDK v1.8  to build the Linux SDK.

But this, Build U-Boot fails with "Your GCC is older than 6.0 ..." 
suggests me to use Ubuntu 18. 

 

How can I get the GCC update without updating my Ubuntu OS? 

Please help. 

 

Thanks,

Shamanth

Outcomes