AnsweredAssumed Answered

Unable to debug demo programs

Question asked by Frank Schoelch on Feb 22, 2019
Latest reply on Mar 14, 2019 by Alice_Yang

Hello,

to upgrade from an old LPC2134 design based on IAR EWARM to LPC54102, I installed the current version of LPCXpresso 8.2.2 under Win7 and purchased the demoboard OM13077.An upgrade to MCUXpresso is not intended at the moment as the old LPC2000 is not supported.

 

For the first test, I tried to debug the periph_blinky program. However this did not work as desired.

 

At first, errors "No source found" were displayed for various adresses 0x... Pressing F8, the application could be set into run mode, but the LED on the demoboard stayed dark. Also, the debugger only showed the .axf under Thread #1 and main() has not been shown.

 

Then I opened the periph_adc and tried to debug this. since then, an error g_pfnVectors() at 0x0 occurs. Pressing F8 leads to the same error within a quarter of a second or so. It has been impossible to run the application at all.

 

I deleted the project directory and started from the beginning, but not the periph_blinky also shows error g_pfnVectors() at 0x0 . I tried to erase the flash using the IC symbol in the ribbon bar, but this leads to a timeout error after about 5 seconds. Reinstalling LPCXpresso did not help.

 

All jumpers on the demoboard are in the factory settings which seems to be correct according to the manual.

Is this a software fault or am I doing something wrong?

 

 

Outcomes