AnsweredAssumed Answered

Accessing CAN Issue in IMX6ULL- evk yocto  

Question asked by bipul pandey on Feb 19, 2019
Latest reply on Mar 12, 2019 by bipul pandey

Hi,

 

I am having an issue to accessing CAN in our hardware while building the yocto image for imx6ul7d. when I used the prebuilt image of imxul7d(rocko) I am able to access CAN.

 

The driver is enumerated and I am able to find in ip link 

root@imx6ul7d:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: can0: <NOARP40000> mtu 16 qdisc noop qlen 10
link/[280]
3: can1: <NOARP40000> mtu 16 qdisc noop qlen 10
link/[280]

 

But when I tried to set the IP, I get an error 

root@imx6ul7d:~# ip link set can0 up type can bitrate 125000
ip: either "dev" is duplicate, or "type" is garbage 

However, I am able to set the bitrate prebuilt image. 

Here is the summery 

 

1. take the prebuilt the image imx6ul7d able to communicate through CAN 

2. Setup the environment fro yocto follow the document  "i.MX_Yocto_Project_User's_Guide"  for imx6uul evk.

3. check all the component of CAN and iproute2 and found everything is fine.

4. checked with rocko, sumo, thud but same issue.

5. I am taken all the documentation form imx6uulevk 

6. I have checked with imx6ull evk and imx6ul7d but same result. 

 

 

what needs to be changed so that I can set bitrate 

what is this issue so we are getting NOARP40000 

Outcomes