AnsweredAssumed Answered

RT1050, RT1060 demo apps don't run from RAM

Question asked by George Pontis on Feb 17, 2019
Latest reply on Mar 6, 2019 by George Pontis

I have been working with the 1050 EVKB, 1060 EVK in MCUXPresso 10.3.0 with SDK 2.5.0. Both USB and LWIP applications build, load, and run fine. However, if I change the Managed Linker option by checking "Load to RAM", and move IT and OC ram to the top, then they both fail.

 

The don't fail completely. One can still start the app in the debugger and step through code. I traced down into the USB initialization and found that everything breaks when the code attempts to write a 0 to the USB Device Address register. By breaking, I mean that the debugger loses control and the app is not running ( so far as I can tell ).

 

I was able to duplicate the breakage by attempting to write that register using the debugger, earlier in the program flow. However, when running the image from flash, there does not seem to be any problem writing that register. So, something in the environment is different in these two cases, and I am hoping someone knows or can suggest some place to look for that difference.

 

I have tried disabling specific interrupts and even all interrupts globally before writing that register, but to no effect. I also tried not enabling the MMU, also without effect.

Outcomes