AnsweredAssumed Answered

FRDM-KW36 Wire ACK Fault in DAP access

Question asked by Rico van de Wetering on Feb 14, 2019
Latest reply on Feb 20, 2019 by Estephania Martinez

Hi,

 

I've did some programming on the FRDM-KW36 board. It wasn't really going as planned... Flashing worked fine though. I tried to upload a hello world example sketch to verify that the board was working. I got a error message with the workspace directory so I temporary made a new workspace2 directory, build the example and tried to program but I got a error message... This has been there and I can't do anything now....

 

Console log:


Executing flash operation 'Program' (Program file into flash: frdmkw36_driver_examples_flexcan_loopback.axf) - Thu Feb 14 17:08:17 CET 2019
Checking MCU info...
Scanning for targets...
Executing flash action...
MCUXpresso IDE RedlinkMulti Driver v10.3 (Nov 28 2018 02:33:57 - crt_emu_cm_redlink.exe build 748)
( 0) Reading remote configuration
Wc(03). No cache support.
Found part description in XML file MKW36Z4_internal.xml
( 5) Remote configuration complete
Reconnected to existing link server
Connecting to probe 1 core 0 (using server started externally) gave 'OK'
============= SCRIPT: kinetisconnect.scp =============
Kinetis Connect Script
Connecting to Probe Index = 1
This probe = 1
This TAP = 0
This core = 0
DpID = 0BC11477
Assert NRESET
Reset pin state: 00
Power up Debug
MDM-AP APID: 0x001C0020
MDM-AP System Reset/Hold Reset/Debug Request
MDM-AP Control: 0x00000008
MDM-AP Status (Flash Ready) : 0x00000036
Part is secured
Mass Erase Required
============= END SCRIPT =============================
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0251000041114e45004b3007bcfe000615d1000097969900
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&2502162e&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0 after searching for a good core
connection failed - Nn(05). Wire ACK Fault in DAP access.. Retrying
Using memory from core 0 after searching for a good core
Failed on connect: Nn(05). Wire ACK Fault in DAP access
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Last stub error 0: OK
Last sticky error: 0x0 AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
(100) Target Connection Failed
error closing down debug session - Nn(05). Wire ACK Fault in DAP access
Unable to perform operation!
Command failed with exit code 1

 

Kind regards,

Outcomes