AnsweredAssumed Answered

Kernel 4.14.78, clock-provider and m41t80.c

Question asked by Patrick Schneider on Feb 14, 2019
Latest reply on Feb 14, 2019 by jimmychan

Hi everyone,

we are using an RTC which depends on the m41t80 kernel driver. This RTC has a CLK-OUT feature which is per default to ON and 32kHz. We have another chip wired and depending to that clock signal.

On kernel version 4.1.15 there was no feature to enable/disable square wave output for this rtc driver, so it was always on per default.

On the new linux-imx 4.14.78 kernel, there was a patch:

adding clock-provider feature linux-imx - i.MX Linux kernel 

 

Which results in the clock output signal being turned of as default option. Now I am totally lost on how to activate that feature in - I think the device tree?

I am not finding proper documentation on that matter. I tried adding clock attributes in the dts but with no luck so far. My entry is:

 

/* external real time clock */
i2c_rtc: rtc@68 {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_rtc_int>;
compatible = "st,rv4162", "fixed-clock", "microcrystal,rv4162";
reg = <0x68>;
interrupt-parent = <&gpio5>;
interrupts = <1 IRQ_TYPE_LEVEL_LOW>;
status = "okay";
#clock-cells = <1>;
clock-frequency = <32678>;
clock-output-names = "rtcosc";
};

 

Any help appreciated!

 

Regards,

Patrick

Outcomes