AnsweredAssumed Answered

Yocto build is ignoring changes in recipe

Question asked by Hector Sanchez on Feb 12, 2019
Latest reply on Feb 14, 2019 by Hector Sanchez
I'm modifying a current recipe that builds onto a Wandboard device using yocto.
I'm having trouble making the bitbake compile my changes using my patch and i want to know if i'm doing something wrong.
First i updated linux-wandboard_3.14.28.bb to add my patch like this: SRC_URI += "\
file://0001-fix-build.patch \
file://0002-fix-build-with-rt-enabled.patch \
file://0003-no-split-ptlocks.patch \
file://0004-imx-sdma-channel-use-raw-spinlock.patch \
file://0005-changes.patch \
"
Where my patch is called 0005-changes.patch.
Then i added my .patch files in the linux-wandboard_3.14.28 folder, where i am sure is reading the patch.
In my patch i'm modifying 3 files:
arch/arm/boot/dts/imx6qdl-wandboard.dtsi | 39 +++-
drivers/video/mxc/mipi_dsi.c | 2 +-
drivers/video/mxc/mxcfb_hx8369_wvga.c | 358 ++++++++++++++++++-------------
When i run the command: "bitbake core-image-sato" yocto is detecting the changes on the linux-wandboard_3.14.28.bb but my patches are not getting applied since i added a syntax mistake on purpose to see if the compiler is really compiling my files but with no success, yocto compiles everything correctly:
NOTE: Tasks Summary: Attempted 5509 tasks of which 5509 didn't need to be rerun and all succeeded.
With this i know that my patches are not getting updated and are not compiling, what i am doing wrong?.
Thank you in advance.
Edit 1: I tried to do my own recipe and i'm getting the same results, my patch is not getting applied since it has syntax mistakes on purpose.

Outcomes