AnsweredAssumed Answered

'bitbake nodejs' results in unrecognized command line option for --mminimal-toc

Question asked by Sebastian Moebus on Feb 7, 2019
Latest reply on Feb 11, 2019 by Pavel Chubakov

Hello,

 

I'm new to this community and started with developing software for B4860 processor just a few weeks ago. At the moment I try to integrate nodejs to my image. I'm using this github project for that: GitHub - imyller/meta-nodejs: OpenEmbedded layer for latest Node.js releases 

My problem:

When I'm running "bitbake nodejs" the following build error occurs:

 

Build Configuration:
BB_VERSION = "1.28.0"
BUILD_SYS = "i686-linux"
NATIVELSBSTRING = "Debian-7.11"
TARGET_SYS = "powerpc64-fsl-linux"
MACHINE = "b4860qds-64b"
DISTRO = "fsl-qoriq"
DISTRO_VERSION = "2.0"
TUNE_FEATURES = "m64 fpu-hard e6500 altivec"
TARGET_FPU = "hard"
meta
meta-yocto
meta-yocto-bsp = "HEAD:9a211a4a2c1bfcb292dc97d8dcac149bca9e3f1b"
meta-oe
meta-multimedia
meta-gnome
meta-networking
meta-perl
meta-python
meta-ruby
meta-filesystems
meta-webserver
meta-xfce = "HEAD:dc5634968b270dde250690609f0015f881db81f2"
meta-freescale = "HEAD:7facbdb726e2dda0515e084c2066a4b8dd99c6d2"
meta-freescale-internal = "HEAD:4829293f807e35a1111e79763294fc8b98b97810"
meta-freescale-extra = "HEAD:bee911b027e0480b034674d0ddee3fcb06d2e985"
meta-virtualization = "HEAD:042425c1d98bdd7e44a62789bd03b375045266f5"
meta-java = "HEAD:8b776ac68f9af4596be3824152bcf0bc6b67fa1d"
meta-openstack
meta-openstack-aio-deploy
meta-openstack-compute-deploy
meta-openstack-compute-test-config
meta-openstack-controller-deploy
meta-openstack-controller-test-config
meta-openstack-qemu
meta-openstack-swift-deploy
meta-cloud-services = "HEAD:d8bc0d92d0f741e2ea1e6d3d9bc6b7a091d03cfb"
meta-security = "HEAD:f9367e71f923fc7d2fb600208e2b97535ea41777"
meta-nodejs = "master:eec531e97a17bfd406f3bf76dee4057dcf5286a4"
meta-nodejs-contrib = "master:22daa0045a3c25cef67446a05a714fc84729bb7b"

NOTE: Preparing RunQueue
NOTE: Checking sstate mirror object availability (for 6 objects)
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: oe_runmake failed
ERROR: Function failed: do_compile (log file is located at /home/sebastian/QorIQ-SDK-V2.0-20160527-yocto/build_b4860qds-64b/tmp/work/ppc64e6500-fsl-linux/nodejs/7.10.0-r1.4/temp/log.do_compile.4325)
ERROR: Logfile of failure stored in: /home/sebastian/QorIQ-SDK-V2.0-20160527-yocto/build_b4860qds-64b/tmp/work/ppc64e6500-fsl-linux/nodejs/7.10.0-r1.4/temp/log.do_compile.4325
Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: make -j 4 -e MAKEFLAGS= BUILDTYPE=Release
| make -C out BUILDTYPE=Release V=1

/atomicops_internals_x86_gcc.o ../deps/v8/src/base/atomicops_internals_x86_gcc.cc

| g++: error: unrecognized command line option '-mminimal-toc'
| make[1]: *** [/home/sebastian/QorIQ-SDK-V2.0-20160527-yocto/build_b4860qds-64b/tmp/work/ppc64e6500-fsl-linux/nodejs/7.10.0-r1.4/node-v7.10.0/out/Release/obj.host/v8_libbase/deps/v8/src/base/atomicops_internals_x86_gcc.o] Error 1

Looks like the compiler that is used by QorIQ SDK v2.0-1703 isn't supporting the -mminimal-toc option.

 

I tried to remove the -mminimal-toc option from the build configuration, but haven't found the point where to do this.

 

Does anybody has an idea how to get rid of this error or how to successfully build nodejs package?

 

BR Sebastian

Outcomes