AnsweredAssumed Answered

Camera preview on i.MX8MQ EVK

Question asked by Felix Radensky on Feb 6, 2019
Latest reply on Feb 13, 2019 by Ofer Austerlitz

Hello,

We are running L4.14.78 GA BSP on NXP i.MX8M EVK board.

The SD card image was downloaded from https://www.nxp.com/webapp/Download?colCode=L4.14.78_1.0.0_MX8MQ&appType=license 

 

Board revision is SCH 29615 REV B3.

We have NXP MX8_DSI_OLED1 display and NXP MINISASTOCSI camera connected to the board as described in application notes:

https://www.nxp.com/webapp/Download?colCode=AN12189 

https://www.nxp.com/webapp/Download?colCode=AN12187 

The DTB file used is fsl-imx8mq-evk-dcss-rm67191-b3.dtb

 

When running camera capture and preview on the connected MIPI display by executing the following commands:

   gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=640,hight=480  ! fpsdisplaysink
   gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=720,height=480  ! fpsdisplaysink
   gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=1280,height=720 ! fpsdisplaysink

 

we get the correct picture.

 

However when using higher resolutions
   gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=1920,height=1080 ! fpsdisplaysink
   gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw,width=2592,height=1944 ! fpsdisplaysink

 

the picture quality worsens, it becomes visibly greener with some parallel lines running across the image.

 

The problem does not occur when previewing on HDMI display. It also does not occur in previous GA BSP release, L4.9.51

We can also reproduce the problem on our own i.MX8MQ boards.

 

Please help us fixing the problem.

 

Felix.

Outcomes