AnsweredAssumed Answered

imx6sx sdb no ethernet

Question asked by David Luberger on Jan 31, 2019
Latest reply on Feb 1, 2019 by igorpadykov

I've tried everything i can think of, but for some reason the ethernet ports only work during bootloading, but not after the board loads into the filesystem. I can see both FEC devices successfully loading during kernel load, but after the device is fully started, i get no lights on either jack, and running ifconfig only gives the lo device, no wired ethernet devices. i've tried all of the dtb files that come with the yocto build. i haven't changed any settings in yocto other than specifying that the machine is imx6sxsabresd.  everything works fine otherwise.  the only clue i have is there is a red "failed" message during linux boot stating "Failed to start Load Kernel Modules".  I'm not sure if that matters because the FEC peripherals aren't compiled as modules.  When I try the demo image that i download from nxp, the ethernet works.

i'm guessing i screwed something up in my yocto settings, for example i edited the core-image-sato and fsl-image-validation-imx bb files directly to add tools and features like evtest, i2ctools, chromium, etc. I don't think that should mess anything up but i'm not sure. I may have messed something else up in the sources folder, i'm not sure.

 

i tried replacing the kernel image with the one that comes with the demo image download and that didn't help, and i didn't expect it too since the kernel reports that the FECs load without a problem.  My only clue is during linux loading it reports "Failed to start Load Kernel Modules", but the service log and dmesg are no help.

I really don't want to have to recompile Chromium, that took a really long time.

Outcomes