AnsweredAssumed Answered

hi everyone i have MCIMX6SX-SDB (Machine model: Freescale i.MX6 SoloX SDB RevB ) type board with Linux version 4.1.15 (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.9) I try use wi-fi module Intel 4965AG and Ericsson H039R but no success.

Question asked by oleg scherbinin on Jan 21, 2019
Latest reply on Jan 23, 2019 by oleg scherbinin

i have MCIMX6SX-SDB (Machine model: Freescale i.MX6 SoloX SDB RevB ) type board with Linux version 4.1.15 (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.9)
I try use wi-fi modules Intel 4965AG and Ericsson H039R but no success.
In my starting kernel log i have:
imx6q-pcie 8ffc000.pcie: phy link never came up
imx6q-pcie 8ffc000.pcie: failed to initialize host
imx6q-pcie: probe of 8ffc000.pcie failed with error -22
lspci command returns nothing.
I do not see "pcie treaning sets" ( interrogation on PCIE_TX_N & PCIE_TX_P pins, i try it by osciloscope with 600MHz bandwidth)

 

 


in my config file i have options:
#Bus support
#
CONFIG_PCI=y
# CONFIG_PCI_DOMAINS_GENERIC is not set
CONFIG_PCI_SYSCALL=y
CONFIG_PCI_MSI=y
# CONFIG_PCI_DEBUG is not set
# CONFIG_PCI_REALLOC_ENABLE_AUTO is not set
# CONFIG_PCI_STUB is not set
# CONFIG_PCI_IOV is not set
# CONFIG_PCI_PRI is not set
# CONFIG_PCI_PASID is not set

#PCI host controller drivers
#
CONFIG_PCIE_DW=y
CONFIG_PCI_IMX6=y
# CONFIG_PCI_IMX6_COMPLIANCE_TEST is not set
# CONFIG_EP_MODE_IN_EP_RC_SYS is not set
CONFIG_RC_MODE_IN_EP_RC_SYS=y
# CONFIG_PCI_IMX_EP_DRV is not set
# CONFIG_PCI_HOST_GENERIC is not set
# CONFIG_PCI_LAYERSCAPE is not set
# CONFIG_PCIE_IPROC is not set
CONFIG_PCIEPORTBUS=y
# CONFIG_PCIEAER is not set
# CONFIG_PCIEASPM is not set
CONFIG_PCIE_PME=y
# CONFIG_PCCARD is not set

# MII PHY device drivers
#
# CONFIG_IWLWIFI is not set
CONFIG_IWLEGACY=y
CONFIG_IWL4965=y

# Bluetooth device drivers
#
CONFIG_MAC80211=y

Thank you,
Oleg.

Outcomes