AnsweredAssumed Answered

Trouble uploading to iMX RT1052 board

Question asked by Dirk-Jan Faber on Jan 18, 2019

Hello,

 

I am having trouble uploading the example code to the  iMX RT1052 evaluation board. This used to work, but for some reason, I am no longer able to upload code to the board, resulting in the following error:

  15: Target error from Commit Flash write
  Target rejected debug access at location 0x20000000
  Debugging context: evkbimxrt1050_lwip_tcpecho_freertos LinkServer Debug

In the configuration, I am using the connect script "RT1050_Debug_Connect.scp", also tried using the connect script "RT1050_SDRAM_Init.scp", but this yielded in the same error.

 

There is no difference in using the laptop USB for powering the board or using an external powersupply. In both cases I get the same error message.

The memory settings from the .cproject file is, as described in :

<memory id="RAM" size="512" type="RAM"/>
<memoryInstance derived_from="Flash" driver="MIMXRT1050-EcoXiP_ATXP032.cfx" edited="true" id="BOARD_FLASH" location="0x60000000" size="0x400000"/>
<memoryInstance derived_from="RAM" edited="true" id="SRAM_DTC" location="0x20000000" size="0x20000"/>
<memoryInstance derived_from="RAM" edited="true" id="SRAM_ITC" location="0x0" size="0x20000"/>
<memoryInstance derived_from="RAM" edited="true" id="SRAM_OC" location="0x20200000" size="0x40000"/>
<memoryInstance derived_from="RAM" edited="true" id="BOARD_SDRAM" location="0x80000000" size="0x2000000"/>

 

I am using the evaluation board from Embedded Artists (iMX RT1052 Developer's Kit - Embedded Artists ) with the scripts from Overview of using the MIMXRT1050-EVK(B) with MCUXpresso IDE . The IDE is MCUXpresso IDE v10.2.1 [Build 795] [2018-07-25] and a ULINK-ME from Keil as debug adapter.

Outcomes