AnsweredAssumed Answered

TWR-VF65GS10(VF610) can't get network access in U-boot

Question asked by Mauricio Agurto on Jan 16, 2019
Latest reply on Jan 24, 2019 by Mauricio Agurto

Hi

 

I am using a TWR-VF65GS10 (VF610) and have built u-boot from these two repositories:

 

https://github.com/u-boot/u-boot

https://github.com/Freescale/u-boot-fslc.git

 


I build u-boot using the default configuration for the microcontroller (vf610twr_defconfig).

The building is successful and I can copy the bootloader to a SDCARD and boot the board. I can also load a kernel image and successfully boot up linux.

 

The problem is that I don't have network access on u-boot. If I try the commands "dhcp" or "tftp" on u-boot, I get:

FEC Waiting for PHY auto negotiation to complete......... TIMEOUT !

Could not initialize PHY FEC

I have tried setting up every network related variable (ip, gateway, ethaddr, fec, etc) and save them (setenv). Same result, no network after boot-up.

 

The only thing that actually gives me network access is to boot up linux followed by :

ifconfig eth0 down

ifconfig eth0 up

After resetting the board, I can have network access on u-boot. However, as soon as I turn the board off and on (removing the power cable), the access is gone.

 

Anybody have a clue about what could be wrong?

 

Thanks in advance

Mauricio

 

PS: I am using a TWR-SER module along with the board.

Outcomes