Vinay Nayak

Linux Booting Issue in M52277EVB board

Discussion created by Vinay Nayak on Jan 7, 2009
Latest reply on Jan 7, 2009 by Tom Thompson

Hi,

We are working with Freescale Coldfire processor MCF52277 based

evaluation board M52277EVB.

 

This board is not booting most of the time. We are using the Freescale

Linux BSPs to load the U-Boot loader and the Linux Kernel.  We are using

the same flash partition which comes along with BSP without modifying a

single bit. Even we are not modified the Linux kernel also. This is the

background information.

 

Problem:

 

This M52277EVB board will not boot most of the time in the morning time

when we first tried to start.  It loads the U-Boot loader and

un-compress the Linux kernel and there it halts.  After loading the

U-boot loader, we are able to execute the U-boot commands. We had tried

to boot manually by giving "boot" command also in the U-boot prompt.

Then also it will not work.

 

After doing around 10-15 times of board reset or so, it boots the Linux

kernel. This repetition of resetting the board we have to do to make

this board warm-up.  Once it boots, it won't give any problem

afterwards. This means that we can reset the board at any number of

times during our working day once it starts working and it boots

properly. But in the morning it won't boot in a single reset.

 

 

Please help us to resolve this issue as soon as possible.

Outcomes