AnsweredAssumed Answered

USB to ehternet adapters for linux:imx6sx 

Question asked by Arun Kamath on Jan 11, 2019
Latest reply on Jan 13, 2019 by igorpadykov

Hi,

 

I am trying to connect a USB to ethernet adapter(ASIX AX88XXX) to the USB OTG1 port on the imx6sx custom board.

I have setup the device tree for the usbotg1 as below, I have enabled the USB net driver CONFIG_USB_NET_AX8817X along with USB_USBNET. but when I plug in the device, the relevant driver is not probed instead the usb device is just populated as Bus 001 Device 001: ID 1d6b:0002 as below: am I missing any other driver or config that is preventing the driver from getting probed?

 

Listing when the device is plugged in:

# ci_hdrc ci_hdrc.0: EHCI Host Controller
ci_hdrc ci_hdrc.0: new USB bus registered, assigned bus number 2
ci_hdrc ci_hdrc.0: USB 2.0 started, EHCI 1.00
usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: EHCI Host Controller
usb usb2: Manufacturer: Linux 4.9.11-rt9 ehci_hcd
usb usb2: SerialNumber: ci_hdrc.0
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected

#
# lsusb -t
Bus 001 Device 001: ID 1d6b:0002

 

Device tree:

reg_usb_otg1_vbus: regulator@5 {
compatible = "regulator-fixed";
reg = <5>;
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_usb_otg1>;
regulator-name = "usb_otg1_vbus";
regulator-min-microvolt = <5000000>;
regulator-max-microvolt = <5000000>;
gpio = <&gpio1 9 GPIO_ACTIVE_HIGH>;
enable-active-high;
};

 

&usbotg1 {
vbus-supply = <&reg_usb_otg1_vbus>;
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_usb_otg1_id>;
disable-over-current;
srp-disable;
hnp-disable;
adp-disable;
dr_mode = "otg";
status = "okay";
};

 

pinctrl_usb_otg1: usbotg1grp {
fsl,pins = <
MX6SX_PAD_GPIO1_IO09__GPIO1_IO_9 0x10b0
>;
};

pinctrl_usb_otg1_id: usbotg1idgrp {
fsl,pins = <
MX6SX_PAD_ENET2_COL__ANATOP_OTG1_ID 0x17059
>;
};

Outcomes