AnsweredAssumed Answered

MCU Linker Issue for Multicore project

Question asked by Gaurav More on Jan 8, 2019
Latest reply on Jan 22, 2019 by Gaurav More

I am using LPC4367. I was using LPC Xpresso but now i want to switch to MCU Xpresso so i have installed MCUXpresso IDE v10.1.0 and created the multicore project for LPC4367. While compiling the project  (M4 Prj) i got follwoing error.

 

Building target: M4_Prj.axf
Invoking: MCU Linker
arm-none-eabi-gcc -nostdlib -L"D:\RELAY DEVLOPMENT\NEW FEEDER RELAY\ESE\Team\Gaurav\Code\MCU\MCU_TestPrj\lpc_chip_43xx\Debug" -Xlinker -Map="M4_Prj.map" -Xlinker --gc-sections -Xlinker -print-memory-usage -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -mthumb -T "M4_Prj_Debug.ld" -o "M4_Prj.axf" ./src/M4_Prj.o ./src/cr_start_m0.o ./src/cr_startup_lpc43xx.o ./src/crp.o ./src/sysinit.o -llpc_chip_43xx

 

/* This is consle window Output*/
c:/nxp/mcuxpressoide_10.1.0_589/ide/tools/bin/../lib/gcc/arm-none-eabi/6.3.1/../../../../arm-none-eabi/bin/ld.exe: No slave code for _core_m0app
M4_Prj_Debug.ld:173: undefined symbol `__vectors_start___core_m0app' referenced in expression
collect2.exe: error: ld returned 1 exit status
make: *** [M4_Prj.axf] Error 1

 

/* This is in problem window*/
make: *** [M4_Prj.axf] Error 1 M4_Prj C/C++ Problem
No slave code for _core_m0app M4_Prj C/C++ Problem
undefined symbol `__vectors_start___core_m0app' referenced in expression M4_Prj_Debug.ld /M4_Prj/Debug line 173 C/C++ Problem

Please find attached code for which is giving this error of linker. 

 

Kinldy provide the solution or let me know if any modification is required in the project created since it is created for M0Sub,M0App, M4.

 

Also let me know whether MCU xpresso supports LPC4367 tricore or not.

 

This similar issue is there in the LPC Xpresso 8.2.2 Version 

Attachments

Outcomes