AnsweredAssumed Answered

iMX8 EVK USB SDP

Question asked by Simon Locke on Jan 7, 2019
Latest reply on Jan 7, 2019 by igorpadykov

Hi

 

I'm trying to build the uboot image from source and download to the iMX8M EVK. I'm starting from the latest 'linux-sumo' 4.14.78 source found here:

 

https://source.codeaurora.org/external/imx/imx-manifest/tree/?h=imx-linux-sumo

 

Everything builds as expected and I can produce a "imx-boot-imx8mqevk-sd.bin-flash_evk" file, which I have selected with the manufacturing tool cfg files (I have previous experience of this from work on iMX6).

 

The processor powers up and I can see the HID device on USB. However when I click start on MfgTool, it does something, and then goes Red to indicate failure. The Console shows the processor starting boot, doing DDR4 training, and then it stops on:

 

Trying to boot from USB SDP

SDP: initialise...

SDP: handle requests...

 

The boot does not progress beyond this. Why?? I notice that the USB device changes from the 1fc9:012b NXP device to a 0525:b4a4 Netchip Technology device. Why is this?

 

I can successfully boot the imx-boot image provided with the mfgtool image I have downloaded, so I know my setup is good (this image boots to uboot console, as I expect).

 

Why does the 'out of the box' image not work for the eval board? Is this an issue, or am I doing something wrong?

 

Note I have also tried booting the image using the imx_loader toolcloned from github, with much the same result.

 

Thanks.

Outcomes