AnsweredAssumed Answered

TJA1022TK not operational

Question asked by Mathieu De Zutter on Jan 5, 2019

Hello all,

 

Lately I've been struggling big time to get a working PCB with the LIN tranciever TJA1022 with package HVSON14. The schematics of the board with the component is well tested on a breadboard with another package (SO14) but the same TJA1022 chip. It works great and the exact same schematic is used on the PCB (see attachment, only the master and slave are inverse but this is resolved in software). 
The chip is wired like the application diagram 12.1 in the datasheet.
The thing that goes wrong on the assembled PCBs is the following:
The MCU on the board (ATSAMD21G18A) stops functioning when a message is tried to send on LIN2. At first I thought it was a software problem with the MCU, but that seems not the case. The MCU seems to stop because of an electrical problem on the TXD2 or RXD2. Those are the only pins connected to the MCU for LIN2. I tried another program on the board to only test the chip and leave other logic out of it. In this program the MCU toggles the pins TXD1 and TXD2 to test them. Then again the MCU stops when toggling the TXD2 pin.It seems the MCU stops because of an overload trying to pull the pin down. On the board I cannot measure directly on the pins of the TJA1022, but I can measure the output of the TJA1022 on LIN1 and LIN2. Both do not respond to a pulse according to my scope.
I then desoldered the chip from the board to check if the program keeps running after sending a message to the chip. The program keeps running, which shows the problem is in the TJA1022 chip.
I even did some more tests. I programmed the MCU to measure the TX. It measured a high level.
This is very odd because the datasheet shows an internal pulldown on TX of the TJA1022.
Is it possible that the chips are damaged by the assembly process? And if so, can I make sure that I don't have that problem again?
Kind regards,
Mathieu

Outcomes