AnsweredAssumed Answered

PN532 tgInitAsTarget command no response

Question asked by Lei jin on Jan 6, 2019
Latest reply on Feb 1, 2019 by Lei jin

Hello everyone, 

I am using on PN532 module (ELECHOUSE v3) as card emulation mode for sometime and it was able to be configured target of ISO-14443 type A card by issuing tgInitAsTarget command and I have made it working as EMV card for contactless transaction of VISA, Mastercrd and AMEX, everything looks fine until today I just rearranged connection wire of the module, then tgInitAsTarget command only return ACK but no information packet followed. I tried to use another working PN532 module (I am sure it is working) and got the same result that no response of tgInitAsTarget. I met this issue at every first beginning when I started to use PN532 as card simulator and that seemed a hardware issue (maybe antenna tuning not properly for that board), then I changed to new PN532 module and the issue gone. Now looks like I was hit again by the same problem. I have read again user manual (141520.pdf) and datasheet (PN532_C1.pdf), and I suspected problem lying at messages exchanges between PN532 and reader: REQA/ATQA ...RATS/ATS that described at page22 of document 41520.pdf. But I don't know why it happened and how to solve it.

Does anybody have met similar issue, and know the solution? Thanks in advance.

.........

tx frame: 00 00 FF 27 D9 D4 8C 04 04 00 12 34 56 20 01 FE A2 A3 A4 A5 A6 A7 C0 C1 C2 C3 C4 C5 C6 C7 FF FF AA 99 88 77 66 55 44 33 22 11 00 00 41 00
ack: 81 00 00 FF 00 FF 00

(I expect to receive following packet from PN532, but unfortunately not)

rx frame: 81 00 00 FF 28 D8 D5 8D 15 25 D4 00 A9 6C 78 8A 3F ED 0A 5B E9 FC 00 00 00 32 46 66 6D 01 01 12 02 02 07 FF 03 02 00 13 04 01 64 07 01 03 0E

.........

Outcomes