Zahir Khan

RiotBoard not executing compiled uBoot image from SD card

Discussion created by Zahir Khan on Dec 24, 2018
Latest reply on Jan 2, 2019 by jimmychan

Hi,

I am trying to port riotboard with linux 4.2 from buildroot build on ubuntu 18.XX.

My problem might sound silly but not able to boot board with compiled uboot image from SD card. Its executing some pre-build image.

Bootup logs:
U-Boot 2009.08-00695-g055df3a (Dec 25 2013 - 09:56:12)
CPU: Freescale i.MX6 family TO1.1 at 792 MHz
Thermal sensor with ratio = 181
Temperature: 30 C, calibration data 0x57b5025f
mx6q pll1: 792MHz
mx6q pll2: 528MHz
mx6q pll3: 480MHz
mx6q pll8: 50MHz
ipg clock : 66000000Hz
ipg per clock : 66000000Hz
uart clock : 80000000Hz
cspi clock : 60000000Hz
ahb clock : 132000000Hz
axi clock : 198000000Hz
emi_slow clock: 99000000Hz
ddr clock : 396000000Hz
usdhc1 clock : 198000000Hz
usdhc2 clock : 198000000Hz
usdhc3 clock : 198000000Hz
usdhc4 clock : 198000000Hz
nfc clock : 24000000Hz
Board: i.MX6DL/Solo-SABRESD: unknown-board Board: 0x61011 [POR ]
Boot Device: SD
I2C: ready
DRAM: 1 GB
MMC: FSL_USDHC: 0,FSL_USDHC: 1,FSL_USDHC: 2,FSL_USDHC: 3
In: serial
Out: serial
Err: serial
Net: got MAC address from IIM: 00:00:00:00:00:00
----enet_board_init: phy reset
FEC0 [PRIME]
Hit any key to stop autoboot: 0
mmc1 is current device
MMC read: dev # 1, block # 2048, count 8192 ... 8192 blocks read: OK
Wrong Image Format for bootm command
ERROR: can't get kernel image!
MX6Solo RIOT U-Boot >


It always bootup probably with default(pre-compiled) uboot (Dec 25 2013 - 09:56:12) . Boot device selected is SD card. But not executing new compiled uboot image from SD card.
Board will bootup even formatted SD card is connected. But board didn't bootup if SD is not connected.
Not understanding from where its executing uboot image & why? (May be SPI flash.. not sure). How the board will execute new compiled uboot image from SD card.
Appreciate your comments & feedback.


Thanks,
Zahir

Outcomes