AnsweredAssumed Answered

Dropdown options empty for PHY component

Question asked by Daniel Näslund on Dec 19, 2018
Latest reply on Dec 19, 2018 by Daniel Näslund

OS: Ubuntu 18.04.1 LTS

IDE:  S32DS Power 2017.R1, Build id: 171018.
SDK: S32PA BETA SDK v1.9.0

SDK example project: phy_autoneg_mpc5748g

BOARD: DEVKIT-MPC5748G

 

The example projects uses ProcessExpert for configuration. When I press the "Generate Processor Expert Code" button in the Components view, the IDE reports these errrors:

Description    Resource    Path    Location    Type
Generator: ERROR: There are errors in the project, please review components configuration. It is not possible to generate code.    phy_autoneg_mpc5748g        Code Generator    Processor Expert Problem
No type specified (Duplex)    phy_autoneg_mpc5748g        ethernet1/Duplex    Processor Expert Problem
No type specified (Mode)    phy_autoneg_mpc5748g        ethernet1/Mode    Processor Expert Problem
No type specified (PHY Location)    phy_autoneg_mpc5748g        phy1/PHY Location    Processor Expert Problem
No type specified (PHY Role)    phy_autoneg_mpc5748g        phy1/PHY Role    Processor Expert Problem
No type specified (PHY Type)    phy_autoneg_mpc5748g        phy1/PHY Type    Processor Expert Problem
No type specified (Speed)    phy_autoneg_mpc5748g        ethernet1/Speed    Processor Expert Problem
Invalid project path: Missing project folder or file: /phy_autoneg_mpc5748g/SDK for Source path.    phy_autoneg_mpc5748g        pathentry    Path Entry Problem

 

If I try to select PHY Type, PHY Location or PHY Role, the drop-down menus are empty. I've tried opening the enet_ping_mpc5748g example project. There, the ENET components drop-down menus was also empty.

 

 

ScreenShot of Component Inspector for PHY

I have been able to build and deploy the hello_world_mpc5748g example project.

 

What steps do I need to take in order to have options available for these components? I've tried inserting numbers and different constants that I found in the source code directory of the SDK but the dropdown-widget didn't accept any of them.

 

I'm attaching my project phy_autoneg_mpc5748g.zip. I created it by

  • selecting File->NEW->From Examples
  • pressed the "Generate Processor Expert Code"
  • Fiddled with the drop-down menus without success

Attachments

Outcomes