AnsweredAssumed Answered

imx8mqevk doesn't have HDMI signal to some monitors

Question asked by Harry Cheng on Dec 12, 2018
Latest reply on Dec 20, 2018 by Ling guan

Hi,

I'm working on an imx8mqevk. It works well, but there is no display when I connect it to some monitors, and the monitors say something like "HDMI no signal".

I tried an image "fsl-image-qt5-validation-imx-imx8mqevk" built for xwayland, and an image build for wayland. The results are same.

There are already some people talking about similar issues, such as:
https://community.nxp.com/thread/471004
https://community.nxp.com/thread/470325
But my issue doesn't look like related to bootargs. If I stop uboot and try something like "printenv", there is something displayed on "good" monitors, but it's still "no signal" on "bad" monitors. Also I tried adding "video=HDMI-A-1:1920x1080-32@60" in bootargs, and it didn't help.

Some raspberrypi users fixed their HDMI issues by configuring their build to force stronger HDMI signal. I couldn't find similar configurations for yocto.

I tried xrandr with my xwayland image. It finds XWAYLAND0 as the monitor, and can't get information of the real monitor even if there is a "good" one connected.

root@imx8mqevk:~# xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
1920x1080 59.96*+
root@imx8mqevk:~#

Thank you for reading the question. Any advice is appreciated.

Outcomes