AnsweredAssumed Answered

yocto4.9.88 compile confuse

Question asked by Cheng Chao on Dec 12, 2018


i am compiling the yocto system,my ubntutu version is 12.04-LTS

my critical command are as follows:

sudo curl > /home/cc/yocto/bin/repo

repo init -u -b imx-linux-rocko -m imx-4.9.88-2.0.0_ga.xml

repo sync

DISTRO=fsl-imx-wayland MACHINE=imx6dlsabresd source -b imx6dl-wayland-qt5

bitbake fsl-image-qt5


and i encountered the problem below:

"ERROR: pango-1.40.6-r0 do_package: Error executing a python function in exec_python_func() autogenerated:"

i just list the first one,because they both due to the python


i viewed the Yocto Project Reference Manual and get some messege

"the required python version is Python 3.4.0 or greater"


i do the command "python --version" on my ubuntu teminal and get the python version is 2.7


so i do the things below

sudo ln -s /usr/bin/python3 /usr/bin/python

python --version

and now the python version messeage is 3.4,now it seems meet the yocto requires,but unfortunately,many commands i exec report error,due to the python version changed; for example,if i keep the default python version2.7,and do "sudo apt-get install vim",it works well;if i changed the select python version to 3.4,the command "sudo apt-get install vim" will

report some error;i guess many system command is based on the default python2.7,after i changed it to python3.4;these system commands runs error;


so i want to take an ensure rely from you

1.the ubuntu system already install python2.7 and python3.4,and the default version is python2.7;should i change the default python version to 3.4,and then bitbake the fsl-image-qt5? if i should do like this,how to resolve the system command exec error due to the change of the default python version?

2.if i just keep the default  python version as 2.7,and the ubuntu system also installed the python3.4;will the command "bitbake fsl-image-qt5" success,will the yocto project find the python version3.4 and work well?

i beg you rely,thanks very much