AnsweredAssumed Answered

About GPIO interrupt issues

Question asked by 鹏 包 on Dec 6, 2018
Latest reply on Dec 6, 2018 by 鹏 包

I am having a problem with a GPIO interrupt configuration.
I used the MCP2515 to do the extended CAN of the S32V234. Now I can find the MCP2515 device in the system, but when I start CAN,
Ip link set can0 up type can bitrate 500000

Report the following error

Root@s32v234sbc:~# ip link set can0 up type can bitrate 500000
[ 43.275115] genirq: Setting trigger mode 2 for irq 117 failed (gic_set_type+0x0/0x48)
[ 43.284214] mcp251x spi0.0: failed to acquire irq 117
[43.290157] A link change request failed with some changes committed already. Interface can0 may have been left with an inconsistent configuration, please check.
RTNETLINK answers: Invalid argument

There should be a problem with the GPIO interrupt set for the MCP2515.
The GPIO interrupt pin assigned to the MCP2515 on the hardware is GPIO15. How do I match it in the configuration? Need a corresponding GIC interrupt?

The current configuration is

Interrupts = <0 15 0x2>;



The above picture is the pin definition I found, this is a multiplexed pin. I also tried 605 but still the same result.

Can anyone tell me how the S32V234SBC interrupt configuration is paired?