AnsweredAssumed Answered

GStreamer - ValueError: Namespace GstRtspServer not available

Question asked by imx learner on Dec 5, 2018
Latest reply on Dec 10, 2018 by imx learner

Hi, 

 

I am trying to use gst-rtsp-server in my python application. for this I included the following : 

      import gi 
     gi.require_version('GstRtspServer','1.0') 
     from gi.repository import GstRtspServer 

 

However, I get the following error: 
  gi.require_version('GstRtspServer','1.0') 
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 130, in require_version 
    raise ValueError('Namespace %s not available' % namespace) 
    ValueError: Namespace GstRtspServer not available 

 

1. Later I tried installing rtsp-server from source from the following repo 
:  https://gitlab.freedesktop.org/gstreamer/gst-rtsp-server.git

 

2. Compiling this gave me an error saying 'Gst-Rtsp.gir' files are missing 
from '/usr/share/gir-1.0'. To resolve this I copied the required '*.gir'  files to  '/usr/share/gir-1.0' from repo : 
https://github.com/sdroege/gstreamer-rs/blob/master/gir-files/GstRtsp-1.0.gir

 

3. make and make install was success. 

 

4. However, when importing this GstRtspServer in my application, I still have the issue : 
    ValueError: Namespace GstRtspServer not available 

 

5. I have seen a number of posts on this issue, and also tried different solutions suggested, however this still is not resolved. 

 

I am using Gstreamer 1.14.1

Does anyone have any pointers towards this issue ? 

 


Regards 

Outcomes