AnsweredAssumed Answered

Errors using LPSPI on RT1050 as Slave

Question asked by Peter Lombrozo on Nov 30, 2018
Latest reply on Dec 18, 2018 by Peter Lombrozo

I'm trying to run the LPSPI examples in the SDK (evkbimxrt1050_cmsis_lpspi_int_b2b_transfer_slave) on my EVKB board with a SPI USB emulator (TotalPhase) as Master on my Windows 10.  I'm able to send correct data to the RT1050, but the return data is corrupted.  In addition to using the CMSIS send/receive commands, I've also tried the Transfer command with the same results. Also tried switching from SPI3 to SPI1 channels that are connected to the J24 connector.


When I try to load the TX data buffer for output to the PC Master with anything other than 0's, even the data *sent* to the RT1050 is corrupted.


I saw that the errata for the RT1050 indicated there is an issue if writing to the TCR then writing to the FIFO (ERR011097).  Does this affect the performance of the LPSPI port in the RT1050?


Thanks for any help you can give me.