AnsweredAssumed Answered

K82: WDOG in Stop mode

Question asked by Eugene Hiihtaja on Nov 29, 2018
Latest reply on Nov 30, 2018 by Jorge Antonio Alcala Vazquez

Hi !

 

I have configured WDOG in way that it require update in Stop mode as well:

 

WDOG_GetDefaultConfig(&config);
config.prescaler = kWDOG_ClockPrescalerDivide1;
config.clockSource = kWDOG_LpoClockSource; // 1ms
config.workMode.enableWait = true; // If update in Wait is required
config.workMode.enableStop = true; // If update in LLS3 is required
config.timeoutValue = 5000; // ms
config.enableWdog = true;
WDOG_Init(WDOG, &config);

/* Accessing register by bus clock. */
for (uint32_t i = 0; i < 256U; i++)
{
(void) WDOG->RSTCNT;
}

 

 

It work fine when RTOS is running and stay under _WFI()

 

But in LLS3 mode it looks like as disabled and reset is not happens.

 

Should it cause reset in LLS3 mode if it not updated by WDOG_Refresh(WDOG) API ?

 

What is right way for update WDOG timeout on fly  ? What should be enabled/disabled or WDOG_Init() with new parameters is OK ?

 

Regards,

Eugene

Outcomes