AnsweredAssumed Answered

Cannot play application with -platform eglfs in Yocto 2.4 image

Question asked by tsung li wang on Nov 27, 2018
Latest reply on Nov 29, 2018 by tsung li wang

Hi Community,

I'm using Yocto project imx-4.9.11_1.0.0_ga and I use i.MX6 sabre-SD Quad as my platform.

 

First to mention, I used Yocto project imx-4.1.15-1.0.0_ga before and build fsl-image-qt5.

For this image, I could run my application with ./application -platform eglfs.

Because I need to use QT version 5.9 so I tried to change it to new Yocto version.

This is the story why I change to imx-4.9.11_1.0.0_ga.

 

But now I had faced the other problem.

I do the exactly the same thing that I did on imx-4.1.15-1.0.0_ga.

However I the image of fsl-image-qt5-validation-imx and fsl-image-qt5 could not use -platform eglfs.

Below is the condition that I build them.

 

For fsl-image-qt5-validation-imx, I use this command "bitbake fsl-image-qt5-validation-imx.".

After bitbake is success, I updated my new root file system to my machine.

Everything look perfect, I could see desktop on my panel.

But while I try to run my application with ./application -platform eglfs, it will show there is no command of eglfs.

 

So I tried to bitbake the other image fsl-image-qt5 and try this one again.

However, it still has no eglfs.

It will show below error message to me.

Available platform plugins are: minimal, offscreen, vnc, wayland-egl, wayland

 

Question

  1. Why there is no eglfs on new yocto version?
  2. Did I miss anything and cause eglfs is not packing in rootfs?

Outcomes