AnsweredAssumed Answered

T4160 detection using Codewarrior

Question asked by Logi Francis on Nov 26, 2018
Latest reply on Nov 27, 2018 by Logi Francis

Hi, 
I am doing the bringup of custom T4160 board. I am using Codewarrior TAP and trying to detect processor through codewarrior connection server. It is detecting as unknown device. The log messages i am getting is given below. What could be the issue? 

 

The same board when i give the RCW source as  'Hard Coded RCW Options' is coming out of reset (HRESET is going high and ASLEEP is going low).

 

******************************************************************************************************

(bin) 2 % source IDcode.tcl

Scanning for available TAPs connected via USB.....


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+
+ Available Remote Connections
+
+ 1 - CodeWarriorTAP - 00:04:9f:04:2b:fa
+ 2 - CodeWarriorTAP - <Specify IP Address>
+ 3 - EthernetTAP - <Specify IP Address>
+ 4 - GigabitTAP - <Specify IP Address>
+
+ x - Exit Script without Changes
+
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Specify connection:
1

Configuring TAP Interface....

Configured Connection: cwtap : 00:04:9f:04:2b:fa


TDO -----
|
* Device 0 IDCODE: 0000808F Device: Unknown Device
|
TDI -----


###################################################
#
# configTAP - Redefine TAP interface
#
# scanboard - Scans the target system
# and returns the JTAG IDCode
#
# ir - Loopback test
#
###################################################

Outcomes