David Yun

Command line build

Discussion created by David Yun on Nov 21, 2018
Latest reply on Nov 22, 2018 by David Yun

I have been running the following batch file script to build a project through command line.

 

SET TOOLCHAIN_PATH=C:\nxp\MCUXpressoIDE_10.2.1_795\ide\tools\bin
SET IDE=C:\nxp\MCUXpressoIDE_10.2.1_795\ide\mcuxpressoidec.exe

 


"%IDE%" -nosplash --launcher.suppressErrors -application org.eclipse.cdt.managedbuilder.core.headlessbuild -import "./LpcLibs\lpc_board_nxp_lpcxpresso_11u68" -import "./LpcLibs\lpc_chip_11u6x" -import "./Adti200Firmware" -cleanBuild Adti200Firmware/Debug

 

Then it doesn't compile the Debug configuration and display the following error:

Project: lpc_board_nxp_lpcxpresso_11u68 already exists in the workspace!

 

So, what I have tried is

- Deleted .metadata and ran the batch file: Got same result as above. 

- Open MCUXpresso IDE and deleted projects without deleting contents: Got same result as above.

 

Anyone have experienced the same issue above?

Outcomes