AnsweredAssumed Answered

MIMXRT1050-EVK(B): MCXpresso - Invalid ID for processor Messag

Question asked by Michael Smorto on Nov 20, 2018
Latest reply on Nov 20, 2018 by Michael Smorto

I have a  MIMXRT1050-EVK(B) board that I have been using now for a week running through examples in the SDK without a problem until I got to Flexcan.  I used both MCXpresso and the MBED compiler without issue, until now. 

 

I did a build and debug of the flexcan_loopback example which worked loaded and ran fine.  So I went ahead and soldered a 3-pin header to J11 to further test flexcan communication.  After I did this I tried to use the flexcan_interrupt_transfer example.  I did a build which ran without issue.  I then did debug to load on the board and received error message about invalid chip id, see below:

MCUXpresso IDE RedlinkMulti Driver v10.2 (Jul 25 2018 11:25:37 - crt_emu_cm_redlink build 555)
Found chip XML file in C:/Users/Merli/Documents/MCUXpressoIDE_10.2.1_795/myworkspace-2/evkbimxrt1050_led_blinky/Debug\MIMXRT1052xxxxB.xml
Reconnected to existing link server
Connecting to probe 1 core 0:0 (using server started externally) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number:  0227000041114e45002a300ac207000f92d1000097969900
VID:PID:  0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&30d89c1b&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0:0 after searching for a good core
connection failed - Ep(03). Invalid ID for processor... Retrying
Using memory from core 0:0 after searching for a good core
Expecting vector catch on SYSRESETREQ signal
Failed on connect: Ep(03). Invalid ID for processor.
Connected&Reset. Was: NotConnected. DpID: 0BD11477. CpuID: 00000FFF. Info: <None>
Last stub error 0: OK
Last sticky error: 0x0 AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.

 

I tried also to load the blinky example but received the same message.

So the question becomes now - how to I fixed this. 

 

Regards

Mike

Outcomes