AnsweredAssumed Answered

VID-PID issue on imx6solo processor.

Question asked by Prasanna Kulkarni on Nov 15, 2018
Latest reply on Nov 20, 2018 by igorpadykov

Hi All,

 

                  We have assembled the imx6solo processor on 20 boards, when we tried to flash using MFG-Tool, We have encountered a very peculiar  issue wrt VID:PID ids. MFG tool expects vid = 0x15A2 and PID =0x0061 id to detect device as HID device otherwise it won't detect. among 20 boards 14 boards are giving different VID and PID such as VID = 0x108C and PID = 0x0156.  so when analyzed these vid pid using usbtrace tool following are the results

On working board:

Hardware ID
 USB\VID_15A2&PID_0061&REV_0001

idVendor
 0x15A2 (Freescale Semiconductor, Inc. )
idProduct
 0x61 (i.MX 6Solo/6DualLite SystemOnChip in RecoveryMode  
iManufacturer
 0x1 (0x409: Freescale SemiConductor Inc )

 

On Non-working board:

Hardware ID
 USB\VID_108C&PID_0156&REV_0001

idVendor
 0x108C (Robert Bosch GmbH ) 
idProduct
 0x156
iManufacturer
 0x1 (0x409: Freescale SemiConductor Inc )

 

  So why there is difference in vid and pid of the devices which are sourced from the same vendor. because it is detecting as Robert Bosch GmbH id MFG-Tool is not detecting the device as HID Complaint. We have manually added the vid pid in ucl2.xml, then it started detecting as "HID-Complaint device" but not able to flash the images. kindly help us in solving this issue. am working for more than 5 years on imx processor, never encountered such issue. where could be the problem? ROM of the processor?? or RAM ??

 

Following are the MFG-Tool Failure Logs after enforcing these different VID PID into ucl2.xml and tried to flash

----------------------------------------------------------------------------------------------------------------------------------------------

DLL version: 2.0.8
Monday, Nov 12, 2018 14:27:56   Start new logging
Mfgtools-Rel-3.0.0_121207_MX6DL_UPDATER\cfg.ini file success[chip: MX6DL Linux Update, List: Android-eMMC]
Mfgtools-Rel-3.0.0_121207_MX6DL_UPDATER\Profiles\MX6DL Linux Update\OS Firmware\ucl2.xml file success
ModuleID[2] LevelID[10]: CMyExceptionHandler thread is running
ModuleID[2] LevelID[1]: new MxHidDeviceClass
ModuleID[2] LevelID[10]: new MxHidDevice[026A72D0]
ModuleID[2] LevelID[10]: Device Manager thread is running
ModuleID[1] LevelID[10]: Initialize Device Manager success
ModuleID[2] LevelID[10]: CmdOperation[0] device chagned and reset to state 0
ModuleID[2] LevelID[10]: ExecuteCommand--Boot[WndIndex:0],

Mfgtools-Rel-3.0.0_121207_MX6DL_UPDATER\Profiles\MX6DL Linux Update\OS Firmware\u-boot-mx6dl-sabresd.bin
ModuleID[2] LevelID[10]: {32,0x020c4018,0x00260324},  
ModuleID[2] LevelID[10]: {32,0x020e0470,0x00000028},  
ModuleID[2] LevelID[10]: {32,0x020e0474,0x00000028},  
----------------------------continues------------------------------
--------------------------------------------------------------------
ModuleID[2] LevelID[10]: {32,0x021b0000,0xc3110000}, 
ModuleID[2] LevelID[10]: {32,0x021b0404,0x00011006},  
ModuleID[2] LevelID[10]: {32,0x021b001c,0x00000000},  
ModuleID[2] LevelID[1]: MxHidDevice::Write() Error writing to device 0x1f.

Outcomes