AnsweredAssumed Answered

Gstreamer colorimetry

Question asked by Quentin Reynard on Nov 12, 2018
Latest reply on Nov 12, 2018 by Quentin Reynard

Hi,

 

I am novice in the use of gstreamer. I want to record the video from a composite camera, but first of all I want to test my pipeline (which produce an error) with videotestsrc.

Here is my command (with gst-launch-1.0 version 1.14.1):

$ gst-launch-1.0 -v videotestsrc ! v4l2h264enc ! filesink location=pal_capture.mkv

which produce the following error:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
/GstPipeline:pipeline0/GstVideoTestSrc:videotestsrc0.GstPad:src: caps = video/x-raw, format=(string)I420, width=(int)320, height=(int)240, framerate=(fraction)30/1, multiview-mode=(string)mono, interlace-mode=(string)progressive, colorimetry=(string)bt601, pixel-aspect-ratio=(fraction)1/1


/GstPipeline:pipeline0/v4l2h264enc:v4l2h264enc0.GstPad:src: caps = video/x-h264, stream-for
mat=(string)byte-stream, alignment=(string)au, profile=(string)baseline, level=(string)4, width=(int)320, height=(int)240, pixel-aspect-ratio=(fraction)1/1, framerate=(fraction)30/1,interlace-mode=(string)progressive, colorimetry=(string)bt601, multiview-mode=(string)mono, multiview-flags=(GstVideoMultiviewFlagsSet)0:ffffffff:/right-view-first/left-flipped/left-flopped/right-flipped/right-flopped/half-aspect/mixed-mono


/GstPipeline:pipeline0/GstFileSink:filesink0.GstPad:sink: caps = video/x-h264, stream-format=(string)byte-stream, alignment=(string)au, profile=(string)baseline, level=(string)4, width=(int)320, height=(int)240, pixel-aspect-ratio=(fraction)1/1, framerate=(fraction)30/1, interlace-mode=(string)progressive, colorimetry=(string)bt601, multiview-mode=(string)mono, multiview-flags=(GstVideoMultiviewFlagsSet)0:ffffffff:/right-view-first/left-flipped/left-flopped/right-flipped/right-flopped/half-aspect/mixed-mono


ERROR: from element /GstPipeline:pipeline0/v4l2h264enc:v4l2h264enc0: Device '/dev/video8' does not support bt601 colorimetry


Additional debug info:
../../../gst-plugins-good-1.14.1/sys/v4l2/gstv4l2object.c(3792): gst_v4l2_object_set_format_full (): /GstPipeline:pipeline0/v4l2h264enc:v4l2h264enc0:
Device wants bt709 colorimetry


ERROR: pipeline doesn't want to preroll.


Setting pipeline to NULL ...
Freeing pipeline ...

 

As the error said, my source (?) does not look like to handle 'bt601 colorimetry'. I tried to change the colorimetry parameter, but without success. Besides, I don't know what /dev/video8 is ?

 

Thanks in advance,

 

Quentin.

Outcomes