AnsweredAssumed Answered

Serial Terminal not working while debugging using J-Link

Question asked by Saranya Chitta on Nov 7, 2018
Latest reply on Nov 8, 2018 by jeremyzhou

Hello,

 

I'm using NXP OM40007 (LPC 54018 IoT Module) to run the hello_world_virtual_com_xip program to the serial terminal (Tera Term) from the demo apps folder of the SDK 2.3.1 using MCUXpresso IDE 10.2.1. I've tried the following:

 

1. At first, I've debugged the program using the Segger J-Link Probe. When I open Tera Term, I'm unable to see the COM Port. I cannot see the COM Port in my Device Manager. Before debugging, I was able to see the COM Port in Device Manager.

2. Secondly, I've tried setting up the Tera Term first and then debugging the code. Initially, Tera Term connected to the board but it got disconnected as soon as I started debugging the code using Segger J-Link. 

3. Later, I've tried to debug the code using Link Server. It shows no compatible probes. 

4. Finally, I've tried to debug the code using Link Server on OM40006 (LPC 54018 IoT Module Baseboard) attached to the OM40007. Tera Term is connected and the code is successfully debugged but I couldn't see the output in the Tera Term. Attached is the screenshot of what's being displayed in the debugger console of the IDE. Serial Terminal configurations were all good as specified. 

 

Also, tried the same on different PCs. 

 

Please help me with this question and let me know if you need any further information.

 

Thanks,

Saranya.

Attachments

Outcomes