AnsweredAssumed Answered

DEVKIT-MPC5748G CAN FD receive not working

Question asked by Katarina Zoric on Nov 2, 2018

Hi,

We ordered two DEVKIT-MPC5748G boards. After failure of S32 Design Studio while trying to debug some code, I unplugged board from USB. After this I tried to debug once more and got the message about reset escalation (and also red reset LED was on). After reading your forums I saw it is bricked and there is no way to unbrick it back. Nonetheless we tried CAN communication using the other board and we succeed to transmit some messages from NXP board to PC, but in the opposite direction doesn't work. We tried it using your flexcan_dma_receive and flexcan_receive functions. Below the message you can see how we checked if CAN frame was received (with turning LED on and using debugger breakpoint). CAN is connected to PC via PEAK Gmbh 4-channel PCIe CAN FD card. Can you please provide some working receiver functions?

 

/*******************************************************************************

Function Name : DMA_16_ISR

Engineer      : b01802

Date          : Oct-15-2015

Parameters    : NONE

Modifies      : NONE

Returns       : NONE

Notes         : Once frame with ID 0x555 is received on CAN1 and DMA channel 16

                moves the frame to RxDATA array, this interrupt is triggered.

Issues        : NONE

*******************************************************************************/

void DMA_0_ISR(void)

{

    / Received frame is available in array RxDATA /

#define LED 148       / pin PJ[4] - LED1 (DS9) on DEV-KIT /

                  / Initialize LED /

                  SIUL2.GPDO[LED / 4].R = 0x00;    / Clear output data before enabling output buffer /

                  SIUL2.MSCR[LED].B.OBE = 1; //SIUL2_MSCR_OBE(1) ;  / Pad PAG2 (98): OBE=1. On EVB active low DS1 LED /

 

    EDMA.INT.R = 0x00000001;      / Clear interrupt flag for DMA channel 0 /

}

Outcomes