AnsweredAssumed Answered

K22F: No UART output after setting clocks to allow VLPR-mode

Question asked by Alexander Farley on Nov 1, 2018
Latest reply on Nov 15, 2018 by Alexander Farley

Hi,

 

I'm trying to set up a K22F project to allow the MCU to enter VLPR mode while still being able to transmit UART output. 

 

I've run into a couple of issues. 

 

1) If I call the function Cpu_VLPModeEnable(), I don't see any UART output afterwards. 

 

2) If I attempt to step over the function Cpu_VLPModeEnable() using the debugger, I get the following from gdb:

Disconnected from "127.0.0.1" via 127.0.0.1
PE-ERROR: GDB Client Processing : Exception Occured : PROGRAM EXCEPTION!
EXCEPTION CLASS: EIDCONNCLOSEDGRACEFULLY
MESSAGE: CONNECTION CLOSED GRACEFULLY.
ADDRESS 0X0046EE0D

Disconnected from "127.0.0.1" via 127.0.0.1
Target Disconnected.

 

Any idea why this might be happening? As I understand, both the UART and the debugger should be able to function in VLPR mode. I suspect this is related to my clock settings but I'm not sure where to start. 

 

One thing that sticks out, is that in the configuration for UART0 in Processor Expert, I see some drop-down boxes for selecting whether the component is enabled in "Low speed mode" or "Slow speed mode". I selected "This component enabled", but the message to the right of the drop-down says "This speed more is disabled in the processor". 

Outcomes