AnsweredAssumed Answered

Disable timer1 interrupt

Question asked by Pierre Le Gargasson on Oct 26, 2018
Latest reply on Nov 5, 2018 by Mario Ignacio Castaneda Lopez

JN-AN-1229-ZBPro-Application-Template

JN5169

 

Hello,

I added a DIO interrupt switch to the demo, sending DIO level from End Device to Coordinator.

Every 5 seconds, timer1 interrupt wakes up to poll. My data only travels from End Device to Coordinator.

I don't need poll request, nether timer1/timer0 interrupts.

I need DIO interrupt in sleep mode.

 

I can't find how to remove timer1 (and timer0) interrupts and keep DIO interrupt still working.

 

If I remove timer1 initialisation (APP_vInitResources => ZQ_vQueueCreate(&zps_TimeEvents,             TIMER_QUEUE_SIZE,      sizeof(zps_tsTimeEvent),     (uint8*)asTimeEvent);

I get APP: Unexpected event in E_NETWORK_JOIN - 21

 

If I go deep in removing interrupt init, DIO interrupts are disabled too.

 

Which part of code should I remove, please ?

Regards,

Pierre

Outcomes