AnsweredAssumed Answered

Ee(42) Could not connect to core - MCUXpresso

Question asked by Harry Bach on Oct 24, 2018
Latest reply on Nov 7, 2018 by Carlos_Mendoza

Using MCUXpresso IDE v10.2.1 on a mac and development board OM40002 - this question is often asked but no solution for the MCUXpresso.

 

I have three development boards with integrated debuggers (OM40002) communicating to MCUXpresso IDE v10.2.1 [Build 795] [2018-07-25] running on a Mac.

 

After a short while the debugger stops responding - a couple of times this has been due to me failing to stop the debugger, other times not. I have got them operating again by simply connecting another development board (OM40002) and debugging on this, then closing down and returning to the original board. But this does not always work, and im down to one operating board, so wish to find the cause/cure. Ive attached two images of the debugger info and the error.

 

The MCUXpresso user guide (v10.2) pages 212-217 has solutions for this. Ive tried killing the debugger by the newly added button on the GUI, Ive tried resetting the debugger via the GUI. Ive tried resetting the debugger via the script (there are two, neither found the debugger because they are looking for a different PID). 

 

I've yet to try reflashing the debugger, partly because I don’t believe this is the problem, partly because I don’t know if the debugger on the OM40002 is Link2? There is reference to its as v1.1 and the support page below confused me further.

 

https://www.nxp.com/support/developer-resources/evaluation-and-development-boards/lpcxpresso-boards:LPCXPRESSO-BOARDS

 

 

Question 1 - How can I re-connect the tool chain to reliably debug the LPC8N04?

Question 2 - What file/process do I perform to re-flash the debugger on the OM40002 (Not sure if its a LINK2 or LINK)?

Outcomes