AnsweredAssumed Answered

Can't connect to LPC11A04UK

Question asked by Louis-Philippe Dion on Oct 22, 2018
Latest reply on Oct 28, 2018 by jeremyzhou

Hi,

 

I've tried to communicate to the LPC11A04UK (WLCSP20 package) without success. I'm using the LPC-Link-2 CMSIS-DAP V5.173

 

I get the following error message : 

 

--------------------------------------------------------------------------------

 

02 : Failed on connect

Could not connect to core.

Emu(0): Connected&Reset. Was: Not Connected. DpID. CpuID: 000000. Info <None>

--------------------------------------------------------------------------------

I'm using PIO0_0 for Reset, PIO0_1 for ISP, PIO0_2 for SWCLK and PIO0_3 for SWDIO.

I added pull-up resistors (100K) on SWCLK and SWDIO close to the LPC11A04UK (Note : I've seen no difference with or without the pull-ups on SWDIO and SWCLK).

I shorted JP2 on LPC-Link-2. Note that my PCB has his own 3.3V. Just in case, I have also tried to use the 3.3V from my PCB to supply the SWD on LPC11A04's side (so JP2 off), but no change.

I didn't shorted JP1.

I use J7 header on LPC-Link-2 to communicate with the target.

I have scoped the Reset and the ISP signals on the LPC11A04UK and they are both pulled down at the beginning.

I have verified the connections of the SWD signals between the LPC4370 (on the LPC-Link-2) and the LPC11A04UK and it is OK.

I have tried several debug configurations, including the one if the attachment.

Every board I tried gave the same error message, as displayed previously.

I joined a scope of SWDIO and SWCLK as a reference.

 

Also, my communication with the LPC4370 seems to be OK since I can manually program a script (program_CMSIS) in it.

 

Any suggestions to help ? I'm out of ideas.

 

Regards,

 

Louis-Philippe

Attachments

Outcomes