AnsweredAssumed Answered

Yocto "bitbake meta-toolchain-qt5" failure

Question asked by shaojun ke on Oct 21, 2018
Latest reply on Oct 22, 2018 by gusarambula

Hi  all:

      I face one issue when using yocto to build tools chain: 

Error: Transaction check error:
file /opt/fsl-imx-fb/4.9.88-2.0.0/sysroots/x86_64-pokysdk-linux/environment-setup.d conflicts between attempted installs of nativesdk-cmake-3.8.2-r0.x86_64_nativesdk and nativesdk-qtbase-tools-5.9.4+git0+0d9208cecb-r0.x86_64_nativesdk

 

My variables, and I build it on Ubuntu 16.04:

Build Configuration:
BB_VERSION = "1.36.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "ubuntu-16.04"
TARGET_SYS = "arm-poky-linux-gnueabi"
MACHINE = "imx6dlsabresd"
DISTRO = "fsl-imx-fb"
DISTRO_VERSION = "4.9.88-2.0.0"
TUNE_FEATURES = "arm armv7a vfp neon callconvention-hard cortexa9"
TARGET_FPU = "hard"

 

Any thoughts on how to fix this?  thanks.

Outcomes