AnsweredAssumed Answered

Cannot change linker script path without changing output path?

Question asked by Curtis Hendrix on Oct 18, 2018
Latest reply on Oct 23, 2018 by LPCX presso support

I'm trying to manually manage the linker scripts for a bootloader project, and I'm having a problem with changing the linker script location.

Since all of the configurations (Debug / Release /etc) for my project use the same linker scripts, I want to put them in main project folder.  By default, the linker scripts get generated in the configuration (Debug/Release) folder.  I'm moving the linker scripts up one directory.


I went into the project properties->C/C++ Build->Settings-MCU Linker->Managed Linker Script, unchecked "Manage linker script", put the name of my linker script in for "Linker script", and set "Script path" to "..\", like so.


That's the only thing I changed in the project properties.

But now the project fails to build with the following error:

arm-none-eabi-gcc.exe: error: RTCP_Host.axf: No such file or directory


I thought the "Script path" only changed where the linker went looking for its script.  Apparently this is not correct.  What exactly does the "Script path" setting change?  And how can I change the linker script location without changing where the output file gets located?