AnsweredAssumed Answered

Unable to boot from emmc

Question asked by stimpy on Oct 16, 2018
Latest reply on Oct 23, 2018 by igorpadykov

Hi,

 

My attempts to boot from internal emmc were in vain. I tried this on a custom board based on the evaluation board 6sx sabre sdb (design files). In our layout we want to use the emmc flash on the periphery SD4 (equivalent to having U4 populated on page 9 in schematic sheets).

Booting from a micro sd card (periphery on SD3) works. 

 

What have I tried?

  1. I have tried with MFG Tool from IMX6_L5.1_2.1.0_MFG_TOOL
    1. I modified the config files according to the attached mfgTool-files.7z . The files in the firmware directory should be the default ones provided by the packages.
    2. Additionally I copied the zImage, the devicetree, the rootfs.tar.bz2 and the u-boot.imx from yocto's deploy folder (after bitbake core-image-sato) to the Profiles/custom/OS Firmware/files directory.
    3. Unfortunately after displaying Jumping to OS image in the tool the process stops with displaying the message 'No Device Connected'. On device's UART one can see the messages, where I don't understand why it waits for mmc1.
      UTP: Waiting for device to appear
      Starting UTP
      uuc 0.5 [built Oct 31 2015 21:15:01]
      UTP: Waiting for device to appear
      mmc1: Timeout waiting for hardware interrupt.
      mmc1: Timeout waiting for hardware interrupt.
    4. After a lot of time (several minuts) and repetition of last line the last outputs on UART are:
      mmc1: Timeout waiting for hardware interrupt.
      mmc3: BKOPS_EN bit is not set
      mmc3: switch to highspeed failed
      mmc3: new MMC card at address 0001
      mmcblk3: mmc3:0001 P1XXXX 3.60 GiB
      mmcblk3boot0: mmc3:0001 P1XXXX partition 1 16.0 MiB
      mmcblk3boot1: mmc3:0001 P1XXXX partition 2 16.0 MiB
      mmcblk3rpmb: mmc3:0001 P1XXXX partition 3 128 KiB
      mmcblk3: p1 p2
      mmcblk3boot1: unknown partition table
      mmcblk3boot0: unknown partition table
      Attached you can find MfgTool.log an the mfg_output.log. 
  2. Flashing with linux:
    1. I tried to copy the whole *.sdcard image to emmc using dd. 
    2. Pulled BT_CFG11 pin to high-level
    3. Devices just doesn't boor nor prints out anything on UART
  3. Flashing with u-boot
    1. Similar to previous point. Flashing *.sdcard (commands used attached in uboot_cmds.txt).
    2. Pulled BT_CFG11 pin to high-level
    3. Flashing doesn't work
    4. What did work is to boot partially from internal emmc by changing 'mmcroot' to
      /dev/mmcblk3p2 rootwait rw

 

So what do I have to change?

Many thanks in advance,

 

Dani

Outcomes