AnsweredAssumed Answered

Error building fsl-image-ubuntu for s32v234evbubuntu

Question asked by kyeonghwa Jeong on Oct 13, 2018
Latest reply on Nov 5, 2018 by Yiping Wang

hi. I got a error messege.

 

mario@mario-HP-ProBook-450-G2:~/bin/build_s32v234evbubuntu$ bitbake fsl-image-ubuntu
Loading cache: 100% |#################################################################################################################################################| Time: 0:00:00
Loaded 1849 entries from dependency cache.
Parsing recipes: 100% |###############################################################################################################################################| Time: 0:01:26
Parsing of 2518 .bb files complete (1423 cached, 1095 parsed). 3428 targets, 188 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies

 

Build Configuration:
BB_VERSION           = "1.36.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "ubuntu-16.04"
TARGET_SYS           = "aarch64-fsl-linux"
MACHINE              = "s32v234evb"
DISTRO               = "fsl-auto"
DISTRO_VERSION       = "1.0"
TUNE_FEATURES        = "aarch64"
TARGET_FPU           = ""
meta                 
meta-poky            
meta-yocto-bsp       = "HEAD:c770664d3125a0a0e73444a3a2a97418b7c0d7a5"
meta-oe              
meta-multimedia      
meta-python          
meta-networking      
meta-gnome           
meta-filesystems     
meta-webserver       
meta-perl            
meta-xfce            = "HEAD:6e3fc5b8d904d06e3aa77e9ec9968ab37a798188"
meta-virtualization  = "HEAD:4277759428e96605b8dbe95a43891e217ae8d399"
meta-freescale       = "HEAD:bf7fd9cfe0788fe2f819a4ae2cc7db8327fe161a"
meta-alb             = "HEAD:c5c6e70fe31c2416cb3681ebfbae9af09c5629fc"
meta-linaro-toolchain = "HEAD:30f0f5e158ba29c4b1ccfdd66f0368726e4179e0"
meta-adas            = "HEAD:bbde7879d1183a01a1a8cccee227d23cb0565be4"

 

Initialising tasks: 100% |############################################################################################################################################| Time: 0:00:05
Checking sstate mirror object availability: 100% |####################################################################################################################| Time: 0:00:00
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: libpython3 rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
ERROR: python3-3.5.3-r1.0 do_package_qa: QA Issue: /usr/lib/libpython3.5m.so.1.0 contained in package libpython3 requires libc.so.6(GLIBC_2.25)(64bit), but no providers found in RDEPENDS_libpython3? [file-rdeps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-dev rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-json rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-textutils rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-core rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-mmap rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-readline rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-lang rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-codecs rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-io rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-unixadmin rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-db rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-gdbm rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-math rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-syslog rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-misc rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-compression rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-sqlite3 rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-xml rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-ctypes rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-profile rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-audio rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-datetime rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-resource rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-crypt rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-multiprocessing rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-fcntl rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-curses rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: python3-3.5.3-r1.0 do_package_qa: QA Issue: python3-subprocess rdepends on ubuntu-base, but it isn't a build dependency, missing ubuntu-base in DEPENDS or PACKAGECONFIG? [build-deps]
ERROR: python3-3.5.3-r1.0 do_package_qa: QA run found fatal errors. Please consider fixing them.
ERROR: python3-3.5.3-r1.0 do_package_qa: Function failed: do_package_qa
ERROR: Logfile of failure stored in: /home/mario/bin/build_s32v234evbubuntu/tmp/work/aarch64-fsl-linux/python3/3.5.3-r1.0/temp/log.do_package_qa.3384
ERROR: Task (/home/mario/bin/sources/poky/meta/recipes-devtools/python/python3_3.5.3.bb:do_package_qa) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1594 tasks of which 1429 didn't need to be rerun and 1 failed.

 

Summary: 1 task failed:
  /home/mario/bin/sources/poky/meta/recipes-devtools/python/python3_3.5.3.bb:do_package_qa
Summary: There were 29 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

Outcomes